36 lines
708 B
Nix
36 lines
708 B
Nix
{
|
|
imports = [
|
|
./hardware-configuration.nix
|
|
../../modules/mailman.nix
|
|
../../roles
|
|
../../roles/vm.nix
|
|
../../modules/vmNetwork.nix
|
|
];
|
|
|
|
# System configuration here
|
|
|
|
services.mathebau-mailman = {
|
|
enable = true;
|
|
hostName = "lists.mathebau.de";
|
|
siteOwner = "root@mathebau.de";
|
|
};
|
|
|
|
networking.hostName = "lobon";
|
|
vmNetwork.ipv4 = "192.168.0.22";
|
|
system.stateVersion = "23.11";
|
|
|
|
sops.secrets = {
|
|
allowlistPass = {
|
|
sopsFile = ./allowlistPass.yaml;
|
|
owner = "mailman";
|
|
group = "mailman";
|
|
mode = "0400";
|
|
};
|
|
backupKey = {
|
|
sopsFile = ./backupKey.yaml;
|
|
owner = "root";
|
|
group = "root";
|
|
mode = "0400";
|
|
};
|
|
};
|
|
}
|